Announcement not sending emails


Home Forums Front End PM PRO Announcement not sending emails

This topic is: Not Resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #16175
    test programmer
    Participant

    I do not receive emails when sending announcements. The user has activated the setting “received by e-mail”. In case of messages I do get the emails.

    In the file front-end-pm-pro/pro/class-fep-email-beautify.php I saw the following:

    add_filter ("fep_announcement_email_send _ {$ post-> ID}", '__return_false'); // this will prevent from email sending

    After I commented this out I’m getting emails. But not in the custom HTML template that I have set in the back office.

    What could be the reason for the above?

    #16184
    shamim
    Keymaster

    Please do not commented that out.
    PRO version announcement emails use queue system. read more in https://www.shamimsplugins.com/docs/front-end-pm-pro/getting-started-2/announcement-email-queue/
    See your setup and wait at least that much time. You can reduce time in setup to trigger quickly. As wordpress cron require visitor to work, make sure you have visitor.

    Let me know.

    #16243
    test programmer
    Participant

    I’ve set my interval at 1 minute.

    I first tried to send announcements with the setting “Send an e-mail to all users when a new message is place” turned on. When I create an announcement, no mails are sent to the receivers. Also, in the overview of messages it shows “emails sent – 0/2”.

    when I switch the setting off then in the overview it shows “emails sent – “2/2”. But I still don’t receive emails.

    What could be the problem here? (I’ve always waited more than 1 minutes before checking)

    #16249
    shamim
    Keymaster

    I have tested again now and working correctly.
    Please check following
    1. Your website can run cron. There are many plugins out there to check.
    2. Go to Dashboard > Front End PM PRO > Emails and check all the fields are filled. Eg. Announcement subject, Announcement content.
    3. refresh your website couple of times after time ends. Eg. you set 1 minute. Then after 1 minute refresh your website
    4. Reduce “Emails send per interval” to 10
    5. If you use any customized email template, make sure no errors are there. Also check your server log if any error there.
    6. You can also check https://codex.wordpress.org/Editing_wp-config.php#Alternative_Cron

    Let me know.

    #16255
    test programmer
    Participant

    1. I’ve installed the WP Crontrol plugin. In the WP-Cron Schedules overview I see the following. There is the fep_ann_email_interval schedule that should run every minute. In the overview of Cron events that you can see here, I don’t see any events related to sending announcement emails.
    2. Template is selected, subject is filled in, content not (because of template).
    3. Done.
    4. Done
    5. Server logs are not showing any errors. Also, wordpress logging is not logging anything.
    6. Added define( 'ALTERNATE_WP_CRON', true ); to wp-config.php but no change.

    It’s really strange, you have any other ideas?

    Attachments:
    You must be logged in to view attached files.
    #16260
    shamim
    Keymaster

    I have also activated WP Crontrol and in WP-Cron Events this plugin event callback is showing (see screenshot). So maybe some other plugin/code is removing this.
    Please change “Sending Interval” to 2 minutes and save changes. Then see if that register cron event again. You can do this couple of times (every time change by 1 or 2 minutes)

    Let me know.

    Attachments:
    You must be logged in to view attached files.
    #16276
    test programmer
    Participant

    I’ve tried to change the interval a couple of times but with no result. The event still doesn’t show in the overview.

    Then I tried to reinstall the plugin. After installation the event was shown in the overview. But after applying my settings (that were set before reinstalling) the event is no longer shown in overview.

    What could be the cause of this? Is it an option you take a look in the backoffice?

    #16279
    shamim
    Keymaster

    did you tried deactivating all plugins except this and change theme to default theme?

    As before reinstall this plugin and change settings except “Sending Interval.” (only this settings change can affect cron).

    Let me know.

Viewing 8 posts - 1 through 8 (of 8 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.