E-Mail Piping Issues


Home Forums Front End PM PRO E-Mail Piping Issues

This topic is: Resolved
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #19894
    H L
    Participant

    Hi,
    I am trying to setup up email piping and followed all instructions. My primary domain name emails are being handled through gsuite so I created a subdomain so that it has direct access to the pipe file.

    I have tried both email piping and piping through pop3 and none seem to work. I have forward emails from reply@subdomain.domain.com {acutal values hidden for privacy} and pointed them to my wordpress directory of where the file is located. I have tried the default directory and I have also tried placing the file in the root directory of /wp-content/

    The email is correctly pointing to the file. When I create a new message both from the [front-end-pm] and [fep_shortcode_new_message_form to=”{current-post-author}” subject=”{current-post-title}”] shortcodes

    The recipients receive an email notification from admin@domain.com email and when they hit reply, the email is sent to reply@subdomain.domain.com {acutal values hidden for privacy}

    After that nothing happens. I don’t get a Email Delivery Fail either from the gmail inbox.

    I am not sure what I need to reconfigure at this point. Please advise.

    #19902
    shamim
    Keymaster

    Can you access inbox of that reply email?If you send an email to your reply@subdomain.domain.com do you receive that email if you access that inbox?

    #19904
    H L
    Participant

    Hi,
    Yes I can. I get the following code:
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    pipe to |/home/domain/public_html/wp/wp-content/fep-email-piping.php
    generated by reply@subdomain.domaind.com

    The following text was generated during the delivery attempt:

    —— pipe to |/home/domain/public_html/wp/wp-content/fep-email-piping.php
    generated by reply@subdomain.domain.com ——

    #19907
    H L
    Participant

    I am using multi version of php. The current php version of my site is PHP 7.0

    I tried changing line 1 to: #!/opt/cpanel/ea-php70/root/usr/bin/php -q
    But I still get delivery failed

    #19910
    H L
    Participant

    A copy of the message replies are getting delivered to my inbox. I can send and receive from that inbox. However, it fails to deliver the email information into the pipe file

    #19913
    H L
    Participant

    Also,
    At the bottom of the email it says “You are blocked. Please contact site administrator if you think there is a problem.”
    I am not sure what is being blocked and how to get it unblocked.

    #19916
    shamim
    Keymaster

    Can you send me full error email you are receiving when deliever failed? (You can change domain/personal info)

    #19918
    H L
    Participant

    Mail Delivery System <Mailer-Daemon@host.domain.com>
    11:19 PM (32 minutes ago)
    to me

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    pipe to |/opt/cpanel/ea-php70/root/usr/bin/php -q /home/gemcrowd/public_html/wp/wp-content/fep-email-piping.php
    generated by reply@subdomain.domain.com

    The following text was generated during the delivery attempt:

    —— pipe to |/opt/cpanel/ea-php70/root/usr/bin/php -q /home/username/public_html/wp/wp-content/fep-email-piping.php
    generated by reply@subdomain.domain.com ——

    You are blocked. Please contact site administrator if you think there is a problem.

    #19921
    shamim
    Keymaster

    Do you use any security plugin which block direct file access? You can deactivate security plugin for testing if that works.

    You can also setup POP3 which works in most of the websites if not all. It query for new emails every hour (may change in future). So after sending reply you have to wait an hour to see if working.

    #19925
    H L
    Participant

    I found out my issue, one of the plugins had IDS Firewall enabled. After disabling, I can now pipe the emails. Works great!

Viewing 10 posts - 1 through 10 (of 10 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.