E-mails not sending when posting announcement


Home Forums Front End PM PRO E-mails not sending when posting announcement

This topic is: Not Resolved
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #17652
    Rob Geers
    Participant

    I can’t seem to get the e-mails sent to users when an announcement is posted. I’ve tried all the suggestions in all the replies in the forum, but I can’t seem to find the solution.

    Can you help me?

    Thanks Rob

    #17655
    shamim
    Keymaster

    Are you getting message notification emails?
    Announcement emails are sent via cron. So it your website cannot run cron then it will not work. Make sure you have visitor on your website.
    Please go to Front End PM PRO > Settings > Emails and see all fields are filled. also check if “Send email to all users when a new announcement is published?” is checked.
    Also change Front End PM PRO > Settings > Emails > Sending Interval to 5 and save changes. it will try every after 5 minutes. Then after 5 minutes refresh your page and see if emails sending. You can see how many email pending by go to Front End PM PRO > All Announcements.

    If still not works please follow https://www.shamimsplugins.com/docs/front-end-pm-pro/troubleshoot/email-notification-not-receiving/

    Let me know.

    #17658
    Rob Geers
    Participant

    Hi, I’ve tried all that. Im receiving mail when i sent a message but not for announcements.

    I get an error in my cron events overview:

    cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

    Bur im not sure thats causing the problem with the announcements, because the website is doing the cronjobs that are scheduled.

    #17661
    shamim
    Keymaster

    did you change Front End PM PRO > Settings > Emails > Sending Interval to 5 and save changes?
    Can you install any cron plugin and run “fep_eb_ann_email_interval_event” cron manually?

    #17705
    Rob Geers
    Participant

    Hi, I did change the sending interval to 5 and run the cronjob manually. I got the message the cronjob was executed succesfully but no change in the sending of the e-mails.

    Any other suggestions?

    Thanks Rob

    #17708
    shamim
    Keymaster

    please check your server error log and see if there is any error.
    Also as you said there is an error in your cron events overview, can you please check from which plugin and/or theme that error came from? Can you deactivate that then try?
    If still not working please deactivate all plugins except this and change theme to unmodified default theme then try. If require you can activate cron plugin to manually run cron. If works then change your theme to your current theme and activate plugins one by one and try. If you found any conflict let me know.

    Also go to Front End PM PRO > All Announcements and see “Email Pending” column to see if that showing pending emails.

    #17770
    Rob Geers
    Participant

    Hi,

    I’ve done all that but even with all plugins switched off and theme set back to default the announcements are not sending.

    It’s shows e-mails are pending on the right side.

    I found one error message on the extensions tab of the plugin:

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/volgspot/staging/2/wp-content/plugins/front-end-pm-pro/admin/extensions.php on line 19

    Any other suggestions? Thanks Rob

    #17776
    shamim
    Keymaster

    Can you give me access to your website so that i can try?
    If yes, please send credentials using https://www.shamimsplugins.com/sensitive-information/ (give me website admin and FTP access, in FTP you can give me permission only content directory)

    #17784
    Rob Geers
    Participant

    I posted the credentials but im not sure it was sent right right. Did you get them?

    Regards Rob

    #17789
    shamim
    Keymaster

    I did not get it. Did it show successfully sent? Please sent again.

    #17861
    Rob Geers
    Participant

    I’ve sent it again. This time i saw the message. Rob

    #17864
    shamim
    Keymaster

    I logged in your website. It is showing cURL error 35. See screenshot. Also it is showing no cron event is firing.

    Please contact your host to solve this issue.

    Attachments:
    You must be logged in to view attached files.
    #17909
    Rob Geers
    Participant

    According to the host the cronjobs are working fine. They tested it. So I don’t think this is going to be solved anytime soon. So I only want to use the messages to send e-mails to the users, but if I turn off Send email to all users when a new announcement is published? the option doesn’t disappear in the options for a user to set his preferences.

    Is there a way to get rid of the option: Email me when new announcement is published?

    Thanks Rob

    #17926
    shamim
    Keymaster

    You can add define( 'ALTERNATE_WP_CRON', true ); in your wp-config.php or add a real cron. See https://www.google.com/search?q=wordpress+real+cron+job

    Let me know.

Viewing 14 posts - 1 through 14 (of 14 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.