Expanding functionality of clean reply quote


Home Forums Front End PM PRO Expanding functionality of clean reply quote

This topic is: Not Resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18930
    xyx
    Participant

    Email replies between users always carry the past email content with unnecessary redundant information (particularly for yahoomail). Is it possible to hide old replied message that comes as an extra information from the email piping on the top of “see original message” feature from yahoo alone.

    In other words, email piping always carry old message with it and show it immediately below the new message. This feature is already available from standard email service and old message relayed with new one even with the clean quote creates more clutter. I would like to hide old message when email is relayed.

    Example of three email exchange with the same message key from yahoo:
    *****************************************************************************
    Hi, this is the third email reply.

    On Thursday, November 8, 2018 xyz blog wrote:

    xyz blog

    Hi, this is the second message.
    On Thursday, November 8, 2018 xyz blog wrote:

    Xyz blog
    *******************************************************************************
    Beside “This is the third email reply” message, all other old message that gets carried on with Date and time who wrote what needs to be removed to make email reply thread more clean.

    #18933
    xyx
    Participant
    This reply has been marked as private.
    #18960
    shamim
    Keymaster

    You can add -----Reply Above This Line----- on top of email content in Front End PM PRO > Settings > Emails. Then add following code in your child theme’s functions.php

    add_filter( 'fep_filter_message_before_send', function( $message ) {
    	$message['message_content'] = strstr( $message['message_content'], '-----Reply Above This Line-----', true ) ?: $message['message_content'];
    	return $message;
    });
    
    #18964
    xyx
    Participant
    This reply has been marked as private.
    #18967
    shamim
    Keymaster

    It means somethings is wrong in your website.
    Please change your theme to unmodified default theme (tweenty*).
    If still have same issue then deactivate all other plugins including all custom plugins. Only keep latest Front End PM PRO active. Then test.

    Let me know.

    #18977
    xyx
    Participant
    This reply has been marked as private.
    #18980
    xyx
    Participant
    This reply has been marked as private.
    #18984
    shamim
    Keymaster

    Did you changed your theme to tweenty* and deactivate all other plugins including all custom plugins except this and test?

    If above steps do not solve your issue please give me access to your test website so that i can test. Please use https://www.shamimsplugins.com/sensitive-information/ for sending credential.

Viewing 8 posts - 1 through 8 (of 8 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.