Full message line break and attachment questions


Home Forums Front End PM PRO Full message line break and attachment questions

This topic is: Not Resolved
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2278
    Chris
    Participant

    Hi Shamim,

    First off, thanks for all your hard work getting this plugin together, it’s been very helpful.

    1. My first question is about the email notifications when a new message is received. The template is displaying the html correctly, so that part is fine. However, when I use the tag {{message}} to display the full message all of the line breaks in the message have been removed.

    Sample full message sent through website or email piping:
    This
    Is
    A
    Test

    What is displayed in the message notification email:
    This Is A Test

    2. This is around email attachments. When someone clicks an attachment it will ask them to save the attachment. If they click the link a second time they get an error message that says, “Invalid Token”. How do I prevent that? And is there a way to just display images in a new tab and let them right click and do a “save as” if they want to keep it?

    3. Also about attachment. When an attachment is uploaded a copy is kept in my media library. However, I can’t view or access the file from there. It just has a standard image placeholder and doesn’t let me see what the image or video was. Is there a way to fix that? I can monitor the messages I’d like to also monitor the attachments.

    Thanks so much in advance for your help with these questions.

    Chris

    #2537
    shamim
    Keymaster

    Sorry for late reply. I was out of internet.
    I will investigate line break issue.
    About attachment right now it will not display in browser but we can introduce that option later.

    Also all attachments will show in media tab in backend where all attachments can be viewed.

    #2573
    Chris
    Participant

    Thanks Shamin,

    And just in case anyone else had my issue with attachments showing up with placeholders in the media library, I just needed to regenerate the thumbnails and they appear fine now.

    I’ll wait to hear back about the like breaks. And I’m sure you’ll come up with a clever way to display attachments in messages in future releases 🙂

    Do you have another update planned anytime soon?

    Thanks,
    Chris

    #2576
    Chris
    Participant

    Oh, and one other feature that would be nice,

    A way for attachments to display in an email notification or at least display a note that says the message has an attachment so they will know to login and check it.

    It’s great that with email piping you can include an attachment in the reply email and that goes to the recipient. Just a bit slow to have to keep logging in to see the attachments 🙂

    Just a thought.
    Thanks again,
    Chris

    #2695
    shamim
    Keymaster

    attachment thumbnail is not generated because it is not used anywhere.
    for line break, you can use nl2br function around email content (temporarily), I will try to investigate more and correct it in next release.
    i actually did not understand you properly what did you expect by display attachment in clever way in message. Please explain a little so that i understand and can try to implement.
    i am working on next version, but will take some time to release.

    #2716
    Chris
    Participant

    Oh, sorry.

    What I meant was a better way to display attachments as part of the message. A way that doesn’t load a new blank page with just a picture. And if you go back to the attachment and click it again it displays an invalid token error. Basically, if pics were sent they would automatically load and be displayed along with the message.

    Thanks,
    Chris

Viewing 6 posts - 1 through 6 (of 6 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.