Replies from FEP Pro web interface are not delivered to real email addresses


Home Forums Front End PM PRO Replies from FEP Pro web interface are not delivered to real email addresses

This topic is: Resolved

Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by  Richard Schletty 2 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1825

    Richard Schletty
    Participant

    My first message gets sent successfully to another user. They see the message in their message center, plus the message gets delivered to their real email address. However, when the recipient clicks on “Please Click the following link to view the message in your web browse” and does a reply from the FEP Pro web interface, the message only appears in the web messages interface. That reply message is not delivered to the real email address. This is a serious problem that must be fixed ASAP. Otherwise I will have to find an alternate solution.

    Is this a problem with the multiple recipients feature being turned on?

    #1828

    shamim
    Keymaster

    Thank you for contacting.
    Please go to Front End PM > settings > Emails and write what email you want to receive when a reply message is sent. Please fill both subject and content field.

    Let me know.

    #1844

    Richard Schletty
    Participant

    Shamim,

    I got it working shortly after I wrote to you (and before I received your kind reply). I had done two things:

    1) Deleted the original free installation of Front End PM.
    2) Copied the template info from Message to Reply.

    From your note, it must have been #2 that fixed it. You should make it clear that the Reply template has to be filled out. I had assumed that it would use the default setup if Reply was empty.

    However, after more testing, replies are still not working in all cases. Here are three ways that the system sometimes fails:

    1) A subscriber can only send a message to an admin using the “Send to Admin” option. The admin receives the email. The admin replies, and the subscriber gets the new message. But when the subscriber replies, the admin does not get a message forwarded to their real email address.

    2) If a member adds an admin to the normal recipient field and sends a message, it is sometimes not received by the admin.

    3) If a subscriber replies to a message thread that has an admin in the normal recipient field, the message is not received by admin.

    In all cases, FEM reports “successfully sent.”

    Is something wrong with permissions? Or is there a bug in the Multiple Recipients option?

    Is there a way to hide some users from the FEM Directory?

    I am using the membership plugin called Paid Memberships Pro.

    #1856

    Richard Schletty
    Participant

    I have another question. In the Parent column of All Messages, what does “No Parent” mean? It appears for some of the messages that have been sent.

    #1860

    shamim
    Keymaster

    Thank you very much for your detail explanation. I will investigate the issue and if found anything will let you know.

    Your issue is for admin email only, can you please check that email address server is ok and does not delay or reject any email? Also if possible keep both admin and subscriber user email in same server and try.

    You can use fep_directory_arguments filter hook to hide users from directory.

    “No Parent” means that message itself is a parent message. And if there is a Parent message in that column that mean that email is a reply message of that parent message.

    #1863

    Richard Schletty
    Participant

    Shammin, I discovered about 4 email notifications that went into my Spam folder in Mac Mail. So it looks like the reply messages are being forwarded to the real email addresses via support@one2oneamerica.com (hosted by SiteGround.com).

    Should I avoid having a forwarder on the support@ address? I currently have support@ emails auto-forwarded to my personal address. Perhaps I should set a donotreply@ address instead with no forwarders.

    I do not know how to use the fep_directory_arguments filter hook to hide users from the directory. How would I specify excluded users and where would I place that code? Into a PHP file? Which one?

    Thank you for your help.

    #1866

    shamim
    Keymaster

    You can use any email address or forwarder, that does not affect this plugin.

    Assume your php version in 5.3+, add following code in your theme’s (child theme’s if any) functions.php to exclude users, change 1,2,3 with your actual user ids

    
    add_filter( 'fep_directory_arguments', function( $args ){
    
    	$args['exclude'] = array( 1, 2, 3 );
    
    	return $args;
    });
    
    #1869

    Richard Schletty
    Participant

    Shamim: I am not a coder so your PHP snippet is vital and most appreciated. I will try adding to functions.php in my child theme.

Viewing 8 posts - 1 through 8 (of 8 total)

You need to purchase ‘Front End PM PRO’ to reply in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.