Site getting a 504 Gateway Time-out error after submitting message


Home Forums Front End PM PRO Site getting a 504 Gateway Time-out error after submitting message

This topic is: Not Resolved
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #15112
    David Hudgins
    Participant

    I am having an issue where the plugin seems to be timing out when submitting a message to a group. I am getting a 504 Gateway Time-out The server didn’t respond in time. – After about 8 seconds.

    The group has about 181 recipients (users). If I go back to the front end and look in the “new messages” the message that was submitted does show up, however there is no email notification sent to any of the users.

    Do you have any recommendations on how to resolve this issue? This issue seemed to start about a week or so ago, and was working fine until then (no new plugins/themes) installed.

    Front End PM Pro version = Version 8.3

    #15115
    David Hudgins
    Participant

    Add on:

    Under Multiple Recipients, there are 2 settings: Max recipients and Message type.

    When a message is submitted to be sent out to a Group (with about 100 recipients), how should setup these settings?

    If i set the Max recipients to 50, and then set message type to Separate Message – when the user submits a message with the plugin attempt to send 2 separate email notifications to 50 users (during that one submission)?

    I am receiving a time out error (504) after submitting to a group (not when sending direct message to other users), and i am wondering if this is the cause (tiring to process multiple email notifications or one big 100 user notification).

    #15128
    shamim
    Keymaster

    “Group Message” and “Multiple Recipient” are separate settings. They act differently.

    Please let me know following
    1. getting 504 when sending group message or multiple recipients (in “To” field)?
    2. How many members you have in group which you are sending to?
    3. Create a test group with 5/6 members and send message to that group, are you getting 504?
    4. How many total messages and announcements you have?
    5. Do you use any caching plugin?

    #15133
    David Hudgins
    Participant

    Thank you for your response.

    1. getting 504 when sending group message or multiple recipients (in “To” field)?

    Just when sending Group messages to any defined group. Direct messages, in the “To” field seem to submit fine – and send email notification.

    2. How many members you have in group which you are sending to?

    Largest group is 181 users, smallest group is 25. Selecting either when creating a new message produced the 504 error after submitting

    3. Create a test group with 5/6 members and send message to that group, are you getting 504?

    Yes, the test group of 5 produced the same 504 error. Typing in all five of the same users (that were in the test 5 group) into the “to” filed and the submitting does not produce error.

    4. How many total messages and announcements you have?

    65 messages total (sent from all users) in backed system. I have 35 in my “inbox” that i am using to test send outs.

    5. Do you use any caching plugin?

    No, at the moment i do not.

    Please let me know if you need anything else or email/DM to gain access for troubleshooting.

    Thank you for your help!

    #15136
    shamim
    Keymaster

    Please enable debug (add define( 'WP_DEBUG', true ); in your wp-config.php) then send a message to group. Let me know if any error shows.
    Also check your server log to see what errors are there.

    Let me know.

    #15139
    David Hudgins
    Participant
    This reply has been marked as private.
    #15142
    shamim
    Keymaster

    Do you use slack? knock me there @shamim51

    #15144
    David Hudgins
    Participant

    I do, but i can’t seem to invite “@shamim51” to a channel or DM. I think i need an email address. I’m I missing something?

    Thank you!

    #15147
    shamim
    Keymaster
    #15152
    David Hudgins
    Participant
    This reply has been marked as private.
    #15384
    David Hudgins
    Participant

    Based on Shamim’s recommendation (after some troubleshooting with him, great support by the way!). Because of the web-server timing out trying to send to so many recipients (over 100) – he recommended i installed a SMTP plugin to do the sending instead. I installed “Easy WP SMTP” to handle the sending out. I happy to say that, at the moment, this has resolved the timing out issue. I also upgraded to the latest version as of posting this (8.3). I will continue to test.

    Thanks to Shamim for his time and effort in finding a solution!

Viewing 11 posts - 1 through 11 (of 11 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.