Some customers are complaining – “Please solve captcha correctly”


Home Forums Advanced noCaptcha & invisible Captcha PRO Some customers are complaining – “Please solve captcha correctly”

This topic is: Resolved
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #39772
    adam.marshall
    Participant

    Settings are setup for v3 invisible with showing the captcha box after 2 attempts. Even after 2 attempts, on multiple browsers, from multiple computers, some customers are not seeing the captcha box and are unable to login. Other customers are having no issues (including myself from an Edge instance, and a Firefox Private Window instance with my test accounts.
    I also notice that the Google icon is not shown on the login form unless you make it a window and scroll so that it appears. The template footer is hiding it – making me think the captcha is also being hidden but I can’t confirm that.

    https://www.ajtek.ca

    Some users are getting the issue, some are not. Registration may also be affected but I have not had anyone confirm that, and I have been receiving new orders so if it’s affected, it’s sporadic like the login page.
    I installed the plugin on the 24th.

    #39811
    shamim
    Keymaster

    please note for V3 google check so many things in background before determining bot or human. It may be browser cookie/cache or anything which making false positive.

    Also in v3 user do not have any option to prove that s/he is human. If it fails, it fails.

    I prefer to use v2 so that if it fails user will have option to prove that s/he is human.

    #39843
    adam.marshall
    Participant

    Do you have any kind of logging capabilities (debug, info, or other) that can be turned on to find out if a) it’s loading correctly, b) find a way to see what’s going on? How can we troubleshoot if the issue is with the plugin and it’s implementation on the site, vs actually google blocking it?

    #39863
    shamim
    Keymaster

    If implementation is incorrect then it should fail in all websites and always. But It seems it is working for some of your users.
    This plugin does not have build in logging but have hook which you can use to log. Please see anr_verify_captcha hook.

    #39866
    adam.marshall
    Participant

    While I would agree with you, I’m going to throw something in there for you to think about…

    A user cannot login to their account, no matter what they do. V3 is enabled on all pages with anr. The customer heads over to my contact form which is using CF7, and is able to send a notification email to me. CF7 is using V3 too.

    So what’s the difference? CF7 is using CF7’s implementation of V3, NOT anr’s shortcode

    So with that information, what are you thinking?

    #39868
    shamim
    Keymaster

    Thank you.
    That is a very good point. I will update you about my finding.
    By this time can you give me a screenshot of the settings page of this plugin in your website? You can mask keys.

    #39871
    adam.marshall
    Participant
    This reply has been marked as private.
    #39927
    shamim
    Keymaster

    Hi again,
    As CF7 load captcha script in all pages, this may create some conflict in other pages not in CF7 page, because this plugin does not load in CF7 page.
    Can you disable captcha in CF7? Just remove keys from CF7 captcha settings. Then see if this working. If you received spam contact messages you can activate https://wordpress.org/plugins/spam-protection-without-captcha/ temporarily which will prevent spam using different approach and will not have any conflict.

    Run one or 2 days for testing. Let me know the result.

    #39971
    adam.marshall
    Participant

    Removed CF7 reCAPTCHA this morning. Since then, I’m still getting reports that different users can’t log in. Dropped the captcha score to 0.3 yesterday too.

    #39974
    shamim
    Keymaster

    I see you are using failed login captcha to 2. That means it will not validate captcha before 2 failed login attempts. Those who are reporting for captcha, how many times they failed? What was the failing reason for first 2 attempts?

    #39978
    adam.marshall
    Participant

    Multiple users using multiple methods of trying to log in. No one sees any Captcha, A few under my direction have browsed the site for a little bit (multiple pages) before clicking on the login button. The same users have tried multiple times (likely over 6) to gain access and each time it gives the same error (which I’ve now adjusted to be a bit more descriptive letting them know we’re using reCAPTCHA v3)

    Attachments:
    You must be logged in to view attached files.
    #39982
    adam.marshall
    Participant

    Can you visit the site and use developer tools to narrow down the problem? I’ve even had my web developer look into this and he’s fixed the placement of the Google Logo so now that it’s in-front of the footer, however that’s only appearance. There’s got to be some sort of troubleshooting that can be done or some log that can be enabled to allow you to figure out what’s going on. It’s not falling back on a ‘display’ of a captcha after 2 failed attempts either.

    #40023
    shamim
    Keymaster

    1. Where did you added that error message? In this plugins settings page?
    2. Are you still using failed login captcha?
    3. Which plugin/theme you are using to create that login form? Can you give me the code of the login form?

    #40040
    adam.marshall
    Participant

    1. Yes, I changed it in the plugin settings page.
    2. Yes, failed logon captcha still set to 2
    3. Using theme Envision – https://themeforest.net/item/envision-responsive-retina-multipurpose-theme/5928018 – I am NOT using the “Envision Custom Login Pages” that comes with it. Can you tell me how to share the code with you for the login form? The “My Account” page just has the shortcode for [woocommerce_my_account]. As far as I know I’m using the standard logon page.

    #40046
    adam.marshall
    Participant

    Please add <?php echo do_shortcode( ‘[anr-captcha]‘ ); ?> in envision/woocommerce/myaccount/form-login.php around line 66

    Fixed the problem. Added this to my child theme files.

Viewing 15 posts - 1 through 15 (of 16 total)

You need to purchase ‘Advanced noCaptcha & invisible Captcha PRO’ to create topic in this support forum.

If you already purchased ‘Advanced noCaptcha & invisible Captcha PRO’ please LOGIN.