Wordfence 2fact authendiacator


Home Forums Advanced noCaptcha & invisible Captcha PRO Wordfence 2fact authendiacator

This topic is: Not Resolved
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #34531
    Stelios Nikolaou
    Participant

    Hello, i have enable the two fact authendicator of wordfence firewall.
    Its not working because its asking to solve captcha without showing the captcha. How can i fix this?

    #34566
    shamim
    Keymaster

    May be it is not compatible with that setup.
    If you cannot make it work with that setup and want a refund please contact using https://www.shamimsplugins.com/contact-us/

    #34577
    Stelios Nikolaou
    Participant

    I prefer for you to help me and explain to me how to add this to that page

    #34598
    shamim
    Keymaster

    As you are using two factor authentication, there is no need to use any captcha.
    Captcha block any bot, as you are already using two factor authentication, bot cannot pass that step. So no need to use captcha there. If you want you can use captcha in any other forms, eg. comment, you can use there. In that case deselect login form captcha.

    #34623
    Stelios Nikolaou
    Participant

    Hi,
    Yes i agree we dont want it there how can i remove it from that page?
    Captcha and 2fact authen are doing totally different jobs. One ads protection from bots spams etc the other extra protection for login and is used only on admins!
    So how can i remove it from wordfence authentication page please
    Other users can login to the site thats why captcha is necessary

    #34656
    shamim
    Keymaster

    You can disable captcha check from login page. Unchecked Login Form from Dashboard > Settings > Advanced noCaptcha & Invisible Captcha

    #34658
    Stelios Nikolaou
    Participant

    i dont want to disable captcha during login.. can you help or not? or can i disable for admin?

    #34665
    shamim
    Keymaster

    Add following code in your child theme’s functions.php (untested)

    add_filter( 'authenticate', function( $user, $username = '', $password = '' ){
        if ( $user instanceof WP_User ) {
    	if ( array_intersect( $user->roles, [ 'administrator' ] ) ) {
    		remove_filter( 'authenticate', array( anr_captcha_class::init(), 'login_verify' ), 999, 3 );
    	}
        }
        return $user;
    }, 990, 3 );
    

    Let me know.

    #34726
    Stelios Nikolaou
    Participant

    Hi,
    The api key is not working. Is show the following in red: Your Advanced noCaptcha & invisible Captcha PRO is not active for this URL. Please visit your account page to manage your license key URLs. The api is correct and its connected in your site.

    #34731
    shamim
    Keymaster
    #34748
    Stelios Nikolaou
    Participant

    ok thanks

Viewing 11 posts - 1 through 11 (of 11 total)

You need to purchase ‘Advanced noCaptcha & invisible Captcha PRO’ to create topic in this support forum.

If you already purchased ‘Advanced noCaptcha & invisible Captcha PRO’ please LOGIN.