Autocomplete and Send Message from Directory not working


Home Forums Front End PM PRO Autocomplete and Send Message from Directory not working

This topic is: Not Resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #10643
    Kevin Manley
    Participant

    Hello again. Neither the Autocomplete function nor the “Send Message” from the Directory listing are working. In fact, I can’t send a message to anyone other than the admin. I can only reply as an admin to someone that has messaged me.

    The fep_to is properly filled in the URL but the TO box is empty. If I manually enter the same username it tells me it is invalid.

    Please advise.

    Kevin

    #10651
    shamim
    Keymaster

    Please check Front End PM PRO > Settings > Security > Role to Role block, if your role is blocked.
    Are you using any custom code for this plugin in your website?
    Can you please deactivate all plugins and change theme to default theme and try?

    #10676
    Kevin Manley
    Participant

    The roles aren’t blocked. The directory listing correctly lists all those that I can send to. I’ve not written any custom code for this. Just installed it last night.

    I’m using Optimizepress. It works if I put the shortcode on a plain wordpress page, but not if I put it on an Optimizepress page. Any advice on how to make this work with OptimizePress?

    Thanks,

    Kevin

    #10680
    shamim
    Keymaster

    i do not have that plugin. If you can send me i can try to find a way if possible.

    #10819
    Kevin Manley
    Participant

    I just created that page without OptimizePress instead and it worked. Thanks for offering to look into it.

    I almost bought another messaging system because it had a feature I really wanted and, possibly, you could add it. I’d like to be able to count the total number of messages my users send and set limits by user level. I’d like to tell users that they will be able to send the admin (support) 10, 20, 100 messages. Right now, it is unlimited and could overwhelm the admin quickly.

    Thanks,

    Kevin

    #10823
    shamim
    Keymaster

    You can set limit from Dashboard > Front End PM PRO > Settings > Misc
    You can set limit as per role.

    #10826
    Kevin Manley
    Participant

    That’s just the number of messages they can keep in the box. I need to limit the total number they are able to send. I want to limit their access to the “expert” in a guided online course.

    Thanks for the reply,
    Kevin

    #10829
    shamim
    Keymaster

    You can add following code in your theme’s (child theme’s if any) functions.php

    
    add_filter( 'fep_current_user_can', function( $can, $cap, $id ){
    	if( 'delete_message' == $cap )
    	return false;
    	
    	return $can;
    }, 10, 3);
    

    This will prevent user to delete their messages from front-end. So they will only be able to send message what is set in that limit page.

    #10833
    Kevin Manley
    Participant

    That does have the same effect. Thanks. However, I’ll still need to go change some of the error messages like “Error: Your message box is full. Please delete some messages.” and I’ll need to remove the “Delete” option from the dropdown or I’ll just annoy my users. Lastly, I need to keep the “Delete” option for the admin role or this will be impossible to manage.

    Thanks for your help. It’s a great plugin!

    Kevin

    #10851
    shamim
    Keymaster

    You can add following code in your theme’s (child theme’s if any) functions.php

    
    add_action( 'fep_action_validate_form', function( $where, $errors, $fields ){
        if( 'newmessage' != $where )
        return;
    
        if ( $errors->get_error_message( 'MgsBoxFull' ) ){
            $errors->remove( 'MgsBoxFull' );
            $errors->add('MgsBoxFull', __( "Your custom error message here.", 'front-end-pm' ));
        }
    }, 99, 3);
    
    add_filter( 'fep_message_table_bulk_actions', function( $actions ){
    	unset( $actions['delete'] );
    	
    	return $actions;
    });
    

    Change error message as you like.
    Admin can delete message from Back-end. Go to Dashboard > Front End PM PRO > All Messages

    #10898
    Kevin Manley
    Participant

    Shamim:

    Wow. You’ve been incredibly helpful. Thank you.

    I do have one last item. How can I disable the search recommendations? Even though I have it set up under “Security” that users are unable to message anyone other than the ADMIN, it’s still listing recommendations. Ideally, I would just set “MAX RECIPIENTS” to 0 so the “TO” box disappears. However, if I do that, then I can no longer initiate messages from the ADMIN to my users.

    Do you follow that?

    Thanks!
    Kevin

    #10907
    shamim
    Keymaster
Viewing 12 posts - 1 through 12 (of 12 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.