Email Sending stays pending unless you change Interval settings


Home Forums Front End PM PRO Email Sending stays pending unless you change Interval settings

This topic is: Resolved
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #32434
    Uğur Terzi
    Participant

    Hello,

    The default emails (password reset etc. ) are able to work without any hassle but the Front End PM PRO’s emails stay “pending” unless you change “Interval settings” from some setting to another (for example 5 min to a minute)

    After you change the Interval it starts to send.

    Do you have any idea?

    Best Regards,
    Ugur

    #32492
    shamim
    Keymaster

    Can you please again check this?
    Please send a new message and wait that much time (set as sending interval). Then refresh your website couple of times. Then see if it started sending emails.
    No need to change sending interval again.

    Let me know.

    #33250
    Uğur Terzi
    Participant

    I already did and tried every possible solution before creating this topic. WP Cron works perfectly fine. There are some other cron jobs that work successfully.
    By the way the hook “fep_email_interval_event” and its action “Fep_Email_Beautify->email_interval_event_callback()” looks work too.
    But somehow it does not send email until you change those two settings; “Email Sending Interval” and “Emails send per interval”

    Best Regards

    Attachments:
    You must be logged in to view attached files.
    #33262
    shamim
    Keymaster

    Is it require to change those 2 settings everytime after sending a message? Or it is just one time?

    #33265
    Uğur Terzi
    Participant

    Yes, emails do not start sending (pending) until you change these settings once or twice.

    #33268
    Uğur Terzi
    Participant

    you need to repeat it every time

    #33296
    shamim
    Keymaster

    Can you give me your website access so that i can test?
    Also please let me know to which user/role i can send test message.

    #33879
    Raymond Lepper
    Participant

    I’ve been having trouble with email sending. I did find that if I changed the interval it would start sending. This is not ideal. I would like it to behave as expected.

    Meanwhile, I am attaching a screen shot of the drop down menu for Email Sending Interval. This seems very odd. Can it be fixed on my end? or through an update?

    Thanks.

    Attachments:
    You must be logged in to view attached files.
    #33911
    shamim
    Keymaster

    @Raymond
    Sometimes it require change interval one time after this plugin install. But it should not require to change this settings anymore.
    Is it require to change this settings after sending every message?
    If it requires please let me know. Also please create a new topic so that i can reply better.

    #34400
    Uğur Terzi
    Participant

    This problem is still going on. Could this method be a solution? I mean disabling WP-Cron and run it via cPanel https://kinsta.com/knowledgebase/disable-wp-cron/

    Thanks

    #34454
    shamim
    Keymaster

    Using system cron in recommended. You can try using that.

    #34457
    Uğur Terzi
    Participant

    I applied the system cron solution then changed the interval settings (because it was not listed in cron events). Now it seems the be appeared in cron events. Let’s see if it can be a solution. I’ll let you know.

    #35121
    Aaku Asujamaa
    Participant

    Hi threre! We have exactly same problem as Ugur and Raymond mentioned. Was there a fix for this or how can this be solved? Thanks.

    #35151
    Uğur Terzi
    Participant

    I disabled the wp-cron and run it manually via Cpanel (*/5 min), here is the link that you can follow: https://kinsta.com/knowledgebase/disable-wp-cron/

    Then I installed the plugin”https://wordpress.org/plugins/wp-crontrol/” and checked the page WP-Cron Events if everything looks ok or not. If everything ok, you should see the “fep_email_interval_event” is on the list and waiting it’s time to run.

    I hope it helps.

    Best Regards,
    Ugur.

    #35231
    Aaku Asujamaa
    Participant

    Thank you so much Ugur! However that sounds quite technical fix for me and I’m not sure that how that affects all the other add-ons and elements on our site which have over 5000 active users.

    There isn’t any official or easier fix for this Shamim?

Viewing 15 posts - 1 through 15 (of 18 total)

You need to purchase ‘Front End PM PRO’ to create topic in this support forum.

If you already purchased ‘Front End PM PRO’ please LOGIN.